Empire Earth 1 AoC FPS + dgvoodoo2 issues

If you're having any technical difficulties with EE, or installing or using the NeoEE patch, make a post here and someone will try and help you out.
Post Reply
Posts: 1
Joined: Sat Nov 21, 2020 8:20 am
Lobby Username: FriendlyAaron69

Empire Earth 1 AoC FPS + dgvoodoo2 issues

Post by FriendlyAaron69 »


I'm having FPS issues with EE:AoC that I bought from GOG. The second there are some units on the screen my FPS plummets to single digits making the game unplayable and making everyone lag in multiplayer.

I've read it somewhere that installing dgvoodoo2 can fix it, so I gave it a try. Everything worked fine in singleplayer, I got normal FPS but with dgvoodoo2 installed I can't access multiplayer. When I click on Multiplayer in the menu the game instantly minimizes to the taskbar and if I bring the game back I can't click on anything anymore as a left or right click results in the game minimizing again.

I'm on Windows 10, and my config is the following:

Intel Core i7 8700
Radeon RX580

The low FPS is not a PC problem as when I install dgvoodoo2 the problem is gone but it breaks multiplayer. My friend who is on Windows 7 has no issues accessing multiplayer with dgvoodoo2 installed. I've tried changing the render settings and decreasing the graphics to minimum + decreasing the resolution to 640x480, messing around with compatibility settings in Windows but nothing helped so far.

Any help with fixing my FPS or allowing me to access multiplayer with dgvoodoo2 installed would be appreciated!

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests